xref: /aoo4110/main/package/util/makefile.mk (revision b1cdbd2c)
1#**************************************************************
2#
3#  Licensed to the Apache Software Foundation (ASF) under one
4#  or more contributor license agreements.  See the NOTICE file
5#  distributed with this work for additional information
6#  regarding copyright ownership.  The ASF licenses this file
7#  to you under the Apache License, Version 2.0 (the
8#  "License"); you may not use this file except in compliance
9#  with the License.  You may obtain a copy of the License at
10#
11#    http://www.apache.org/licenses/LICENSE-2.0
12#
13#  Unless required by applicable law or agreed to in writing,
14#  software distributed under the License is distributed on an
15#  "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
16#  KIND, either express or implied.  See the License for the
17#  specific language governing permissions and limitations
18#  under the License.
19#
20#**************************************************************
21
22
23
24# 2 == Unicode
25MAJOR_VERSION=2
26
27PRJ=..
28PRJNAME=package
29TARGET=package
30
31ENABLE_EXCEPTIONS=TRUE
32USE_DEFFILE=TRUE
33NO_BSYMBOLIC=TRUE
34
35
36# --- Settings -----------------------------------------------------
37
38.INCLUDE :  settings.mk
39
40.IF "$(L10N_framework)"==""
41
42# --- General ----------------------------------------------------
43
44LIB1TARGET= $(SLB)$/$(TARGET).lib
45LIB1FILES=	\
46    $(SLB)$/zipapi.lib \
47    $(SLB)$/zippackage.lib \
48    $(SLB)$/manifest.lib
49
50# --- Shared-Library -----------------------------------------------
51
52SHL1TARGET=$(TARGET)$(MAJOR_VERSION)
53SHL1IMPLIB=i$(TARGET)
54SHL1VERSIONMAP=$(SOLARENV)$/src$/component.map
55
56SHL1STDLIBS=\
57	$(CPPULIB)		\
58	$(UCBHELPERLIB)		\
59	$(CPPUHELPERLIB)	\
60	$(COMPHELPERLIB)		\
61	$(SALLIB)		\
62	$(ZLIB3RDLIB)	\
63	$(SAXLIB)
64
65SHL1DEF=$(MISC)$/$(SHL1TARGET).def
66SHL1LIBS=$(LIB1TARGET)
67DEF1NAME=$(SHL1TARGET)
68
69.ENDIF # L10N_framework
70
71# --- Targets ----------------------------------------------------------
72
73.INCLUDE :  target.mk
74
75
76ALLTAR : $(MISC)/package2.component
77
78$(MISC)/package2.component .ERRREMOVE : $(SOLARENV)/bin/createcomponent.xslt \
79        package2.component
80    $(XSLTPROC) --nonet --stringparam uri \
81        '$(COMPONENTPREFIX_BASIS_NATIVE)$(SHL1TARGETN:f)' -o $@ \
82        $(SOLARENV)/bin/createcomponent.xslt package2.component
83