130cfceefSAndrew Rist# *************************************************************
230cfceefSAndrew Rist#
330cfceefSAndrew Rist#  Licensed to the Apache Software Foundation (ASF) under one
430cfceefSAndrew Rist#  or more contributor license agreements.  See the NOTICE file
530cfceefSAndrew Rist#  distributed with this work for additional information
630cfceefSAndrew Rist#  regarding copyright ownership.  The ASF licenses this file
730cfceefSAndrew Rist#  to you under the Apache License, Version 2.0 (the
830cfceefSAndrew Rist#  "License"); you may not use this file except in compliance
930cfceefSAndrew Rist#  with the License.  You may obtain a copy of the License at
1030cfceefSAndrew Rist#
1130cfceefSAndrew Rist#    http://www.apache.org/licenses/LICENSE-2.0
1230cfceefSAndrew Rist#
1330cfceefSAndrew Rist#  Unless required by applicable law or agreed to in writing,
1430cfceefSAndrew Rist#  software distributed under the License is distributed on an
1530cfceefSAndrew Rist#  "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
1630cfceefSAndrew Rist#  KIND, either express or implied.  See the License for the
1730cfceefSAndrew Rist#  specific language governing permissions and limitations
1830cfceefSAndrew Rist#  under the License.
1930cfceefSAndrew Rist#
2030cfceefSAndrew Rist# *************************************************************
21cdf0e10cSrcweir# version and release passed by command-line
22cdf0e10cSrcweirVersion: %version
23cdf0e10cSrcweirRelease: %release
24cdf0e10cSrcweirSummary: %productname desktop integration
25cdf0e10cSrcweirName: %pkgprefix-redhat-menus
26cdf0e10cSrcweirGroup: Office
27bda541ebSArmin Le GrandLicense: ALv2
28bda541ebSArmin Le GrandVendor: Apache Software Foundation
29cdf0e10cSrcweirAutoReqProv: no
30cdf0e10cSrcweirBuildArch: noarch
31*891164acSAriel Constenla-HaileObsoletes: openoffice.org3.0-redhat-menus
32*891164acSAriel Constenla-HaileObsoletes: openoffice.org3.1-redhat-menus
33*891164acSAriel Constenla-HaileObsoletes: openoffice.org3.2-redhat-menus
34*891164acSAriel Constenla-HaileObsoletes: openoffice.org3.3-redhat-menus
35*891164acSAriel Constenla-HaileObsoletes: openoffice.org3.4-redhat-menus
36cdf0e10cSrcweirRequires: redhat-release
37599cc5b4SOliver-Rainer WittmannProvides: openoffice-desktop-integration
38cdf0e10cSrcweir%define _unpackaged_files_terminate_build 0
39cdf0e10cSrcweir%define _binary_filedigest_algorithm 1
40cdf0e10cSrcweir%define _binary_payload w9.gzdio
41cdf0e10cSrcweir%description
42cdf0e10cSrcweir%productname desktop integration
43cdf0e10cSrcweir
44cdf0e10cSrcweir%install
45cdf0e10cSrcweir# hack/workaround to make SuSE's brp-symlink-script happy. It wants the targets of all links
46cdf0e10cSrcweir# to be present on the build-system/the buildroot. But the point is that we generate stale
47cdf0e10cSrcweir# links intentionally (until we find a better solution) #46226
48cdf0e10cSrcweirexport NO_BRP_STALE_LINK_ERROR=yes
49cdf0e10cSrcweir
50cdf0e10cSrcweirmkdir -p $RPM_BUILD_ROOT
51cdf0e10cSrcweir
52cdf0e10cSrcweir# set parameters for the create_tree script
53cdf0e10cSrcweirexport DESTDIR=$RPM_BUILD_ROOT
54cdf0e10cSrcweirexport KDEMAINDIR=/usr
55cdf0e10cSrcweirexport GNOMEDIR=/usr
56cdf0e10cSrcweirexport GNOME_MIME_THEME=hicolor
57cdf0e10cSrcweir
58cdf0e10cSrcweir./create_tree.sh
59cdf0e10cSrcweir
60cdf0e10cSrcweir# legacy redhat KDE location for .desktop files
61cdf0e10cSrcweirmkdir -p $RPM_BUILD_ROOT/usr/share/applnk-redhat/Office
62cdf0e10cSrcweirfor i in `cat launcherlist`; do
63cdf0e10cSrcweir  ln -sf /opt/%unixfilename/share/xdg/$i $RPM_BUILD_ROOT/usr/share/applnk-redhat/Office/%unixfilename-$i
64cdf0e10cSrcweirdone
65cdf0e10cSrcweir
66cdf0e10cSrcweir%clean
67cdf0e10cSrcweirrm -rf $RPM_BUILD_ROOT
68cdf0e10cSrcweir
69cdf0e10cSrcweir%triggerin --  %pkgprefix, %pkgprefix-writer, %pkgprefix-calc, %pkgprefix-draw, %pkgprefix-impress, %pkgprefix-base, %pkgprefix-math
70cdf0e10cSrcweirif [ -x /usr/bin/update-desktop-database ]; then
71cdf0e10cSrcweir  update-desktop-database -q /usr/share/applications
72cdf0e10cSrcweirfi
73cdf0e10cSrcweir
74cdf0e10cSrcweir%triggerun --  %pkgprefix, %pkgprefix-writer, %pkgprefix-calc, %pkgprefix-draw, %pkgprefix-impress, %pkgprefix-base, %pkgprefix-math
75cdf0e10cSrcweirif [ "$1" = "0" ] ; then
76cdf0e10cSrcweir  # the menu-package gets uninstalled/updated - postun will run the command
77cdf0e10cSrcweir  exit 0
78cdf0e10cSrcweirfi
79cdf0e10cSrcweirif [ "$2" = "0" ] ; then
80cdf0e10cSrcweir  # the triggering package gets removed
81cdf0e10cSrcweir  if [ -x /usr/bin/update-desktop-database ]; then
82cdf0e10cSrcweir    update-desktop-database -q /usr/share/applications
83cdf0e10cSrcweir  fi
84cdf0e10cSrcweirfi
85cdf0e10cSrcweir
86cdf0e10cSrcweir%post
87cdf0e10cSrcweir# run always, since there are versions of this package that did not include
88cdf0e10cSrcweir# a shared-mime-info xml file
89cdf0e10cSrcweirif [ -x /usr/bin/update-mime-database ]; then
90cdf0e10cSrcweir  update-mime-database /usr/share/mime
91cdf0e10cSrcweirfi
92cdf0e10cSrcweir
93cdf0e10cSrcweir# run only on first install, since postun is run when updating
94cdf0e10cSrcweir# post would be run before the old files are removed
95cdf0e10cSrcweirif [ "$1" = "1" ] ; then  # first install
96cdf0e10cSrcweir  for theme in gnome hicolor locolor; do
97cdf0e10cSrcweir    if [ -e /usr/share/icons/$theme/icon-theme.cache ] ; then
98cdf0e10cSrcweir      # touch it, just in case we cannot find the binary...
99cdf0e10cSrcweir      touch /usr/share/icons/$theme
100cdf0e10cSrcweir      if (which gtk-update-icon-cache); then
101cdf0e10cSrcweir        gtk-update-icon-cache /usr/share/icons/$theme
102cdf0e10cSrcweir      fi
103cdf0e10cSrcweir      # ignore errors (e.g. when there is a cache, but no index.theme)
104cdf0e10cSrcweir      true
105cdf0e10cSrcweir    fi
106cdf0e10cSrcweir  done
107cdf0e10cSrcweirfi
108cdf0e10cSrcweir
109cdf0e10cSrcweir# update /etc/mime.types
110cdf0e10cSrcweir# backing out existing entries to avoid duplicates
111cdf0e10cSrcweirsed '
112cdf0e10cSrcweir/application\/vnd\.oasis\.opendocument/d
113cdf0e10cSrcweir/application\/vnd\.openofficeorg/d
114cdf0e10cSrcweir/application\/vnd\.sun/d
115cdf0e10cSrcweir/application\/vnd\.stardivision/d
116cdf0e10cSrcweir' /etc/mime.types 2>/dev/null >> /etc/mime.types.tmp$$
117cdf0e10cSrcweir
118cdf0e10cSrcweir# now append our stuff to the temporary file
119cdf0e10cSrcweircat >> /etc/mime.types.tmp$$ << END
120cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text	odt
121cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-template ott
122cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-web oth
123cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-master odm
124cdf0e10cSrcweirapplication/vnd.oasis.opendocument.graphics odg
125cdf0e10cSrcweirapplication/vnd.oasis.opendocument.graphics-template otg
126cdf0e10cSrcweirapplication/vnd.oasis.opendocument.presentation odp
127cdf0e10cSrcweirapplication/vnd.oasis.opendocument.presentation-template otp
128cdf0e10cSrcweirapplication/vnd.oasis.opendocument.spreadsheet ods
129cdf0e10cSrcweirapplication/vnd.oasis.opendocument.spreadsheet-template ots
130cdf0e10cSrcweirapplication/vnd.oasis.opendocument.chart odc
131cdf0e10cSrcweirapplication/vnd.oasis.opendocument.formula odf
132cdf0e10cSrcweirapplication/vnd.oasis.opendocument.image odi
133cdf0e10cSrcweirapplication/vnd.sun.xml.writer sxw
134cdf0e10cSrcweirapplication/vnd.sun.xml.writer.template stw
135cdf0e10cSrcweirapplication/vnd.sun.xml.writer.global sxg
136cdf0e10cSrcweirapplication/vnd.stardivision.writer sdw vor
137cdf0e10cSrcweirapplication/vnd.stardivision.writer-global sgl
138cdf0e10cSrcweirapplication/vnd.sun.xml.calc sxc
139cdf0e10cSrcweirapplication/vnd.sun.xml.calc.template stc
140cdf0e10cSrcweirapplication/vnd.stardivision.calc sdc
141cdf0e10cSrcweirapplication/vnd.stardivision.chart sds
142cdf0e10cSrcweirapplication/vnd.sun.xml.impress sxi
143cdf0e10cSrcweirapplication/vnd.sun.xml.impress.template sti
144cdf0e10cSrcweirapplication/vnd.stardivision.impress sdd sdp
145cdf0e10cSrcweirapplication/vnd.sun.xml.draw sxd
146cdf0e10cSrcweirapplication/vnd.sun.xml.draw.template std
147cdf0e10cSrcweirapplication/vnd.stardivision.draw sda
148cdf0e10cSrcweirapplication/vnd.sun.xml.math sxm
149cdf0e10cSrcweirapplication/vnd.stardivision.math smf
150cdf0e10cSrcweirapplication/vnd.sun.xml.base odb
151cdf0e10cSrcweirapplication/vnd.openofficeorg.extension oxt
152cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.wordprocessingml.document docx
153cdf0e10cSrcweirapplication/vnd.ms-word.document.macroenabled.12 docm
154cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.wordprocessingml.template dotx
155cdf0e10cSrcweirapplication/vnd.ms-word.template.macroenabled.12 dotm
156cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.spreadsheetml.sheet xlsx
157cdf0e10cSrcweirapplication/vnd.ms-excel.sheet.macroenabled.12 xlsm
158cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.spreadsheetml.template xltx
159cdf0e10cSrcweirapplication/vnd.ms-excel.template.macroenabled.12 xltm
160cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.presentationml.presentation pptx
161cdf0e10cSrcweirapplication/vnd.ms-powerpoint.presentation.macroenabled.12 pptm
162cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.presentationml.template potx
163cdf0e10cSrcweirapplication/vnd.ms-powerpoint.template.macroenabled.12 potm
164cdf0e10cSrcweirEND
165cdf0e10cSrcweir
166cdf0e10cSrcweir# and replace the original file
167cdf0e10cSrcweirmv -f /etc/mime.types.tmp$$ /etc/mime.types 2>/dev/null
168cdf0e10cSrcweir
169cdf0e10cSrcweir# update /etc/mailcap only at initial install
170cdf0e10cSrcweirif [ "$1" = 1 ]
171cdf0e10cSrcweirthen
172cdf0e10cSrcweir  # backing out existing entries to avoid duplicates
173cdf0e10cSrcweir  sed '
174cdf0e10cSrcweir/^# OpenOffice.org/d
175cdf0e10cSrcweir/^application\/vnd\.oasis\.opendocument/d
176cdf0e10cSrcweir/^application\/vnd\.openofficeorg/d
177cdf0e10cSrcweir/^application\/vnd\.sun/d
178cdf0e10cSrcweir/^application\/vnd\.stardivision/d
179cdf0e10cSrcweir/^application\/vnd\.ms-word/d
180cdf0e10cSrcweir/^application\/vnd\.ms-excel/d
181cdf0e10cSrcweir/^application\/vnd\.ms-powerpoint/d
182cdf0e10cSrcweir/^application\/x-star/d
183cdf0e10cSrcweir/excel/d
184cdf0e10cSrcweir/ms[-]*word/d
185cdf0e10cSrcweir/powerpoint/d
186cdf0e10cSrcweir' /etc/mailcap 2>/dev/null >> /etc/mailcap.tmp$$
187cdf0e10cSrcweir
188cdf0e10cSrcweir  # now append our stuff to the temporary file
189cdf0e10cSrcweir  cat >> /etc/mailcap.tmp$$ << END
190bda541ebSArmin Le Grand# Apache OpenOffice
191cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text; %unixfilename -view %s
192cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-template; %unixfilename -view %s
193cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-web; %unixfilename -view %s
194cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-master; %unixfilename -view %s
195cdf0e10cSrcweirapplication/vnd.sun.xml.writer; %unixfilename -view %s
196cdf0e10cSrcweirapplication/vnd.sun.xml.writer.template; %unixfilename -view %s
197cdf0e10cSrcweirapplication/vnd.sun.xml.writer.global; %unixfilename -view %s
198cdf0e10cSrcweirapplication/vnd.stardivision.writer; %unixfilename -view %s
199cdf0e10cSrcweirapplication/vnd.stardivision.writer-global; %unixfilename -view %s
200cdf0e10cSrcweirapplication/x-starwriter; %unixfilename -view %s
201cdf0e10cSrcweirapplication/vnd.oasis.opendocument.formula; %unixfilename -view %s
202cdf0e10cSrcweirapplication/vnd.sun.xml.math; %unixfilename -view %s
203cdf0e10cSrcweirapplication/vnd.stardivision.math; %unixfilename -view %s
204cdf0e10cSrcweirapplication/x-starmath; %unixfilename -view %s
205cdf0e10cSrcweirapplication/msword; %unixfilename -view %s
206cdf0e10cSrcweirapplication/vnd.oasis.opendocument.spreadsheet; %unixfilename -view %s
207cdf0e10cSrcweirapplication/vnd.oasis.opendocument.spreadsheet-template; %unixfilename -view %s
208cdf0e10cSrcweirapplication/vnd.sun.xml.calc; %unixfilename -view %s
209cdf0e10cSrcweirapplication/vnd.sun.xml.calc.template; %unixfilename -view %s
210cdf0e10cSrcweirapplication/vnd.stardivision.calc; %unixfilename -view %s
211cdf0e10cSrcweirapplication/x-starcalc; %unixfilename -view %s
212cdf0e10cSrcweirapplication/vnd.stardivision.chart; %unixfilename -view %s
213cdf0e10cSrcweirapplication/x-starchart; %unixfilename -view %s
214cdf0e10cSrcweirapplication/excel; %unixfilename -view %s
215cdf0e10cSrcweirapplication/msexcel; %unixfilename -view %s
216cdf0e10cSrcweirapplication/vnd.ms-excel; %unixfilename -view %s
217cdf0e10cSrcweirapplication/x-msexcel; %unixfilename -view %s
218cdf0e10cSrcweirapplication/vnd.oasis.opendocument.presentation; %unixfilename -view %s
219cdf0e10cSrcweirapplication/vnd.oasis.opendocument.presentation-template; %unixfilename -view %s
220cdf0e10cSrcweirapplication/vnd.sun.xml.impress; %unixfilename -view %s
221cdf0e10cSrcweirapplication/vnd.sun.xml.impress.template; %unixfilename -view %s
222cdf0e10cSrcweirapplication/vnd.stardivision.impress; %unixfilename -view %s
223cdf0e10cSrcweirapplication/x-starimpress; %unixfilename -view %s
224cdf0e10cSrcweirapplication/powerpoint; %unixfilename -view %s
225cdf0e10cSrcweirapplication/mspowerpoint; %unixfilename -view %s
226cdf0e10cSrcweirapplication/vnd.ms-powerpoint; %unixfilename -view %s
227cdf0e10cSrcweirapplication/x-mspowerpoint; %unixfilename -view %s
228cdf0e10cSrcweirapplication/vnd.oasis.opendocument.graphics; %unixfilename -view %s
229cdf0e10cSrcweirapplication/vnd.oasis.opendocument.graphics-template; %unixfilename -view %s
230cdf0e10cSrcweirapplication/vnd.sun.xml.draw; %unixfilename -view %s
231cdf0e10cSrcweirapplication/vnd.sun.xml.draw.template; %unixfilename -view %s
232cdf0e10cSrcweirapplication/vnd.stardivision.draw; %unixfilename -view %s
233cdf0e10cSrcweirapplication/x-stardraw; %unixfilename -view %s
234cdf0e10cSrcweirapplication/vnd.oasis.opendocument.database; %unixfilename -view %s
235cdf0e10cSrcweirapplication/vnd.sun.xml.base; %unixfilename -view %s
236cdf0e10cSrcweirapplication/vnd.writerperfect; %unixfilename -view %s
237cdf0e10cSrcweirapplication/wordperfect5.1; %unixfilename -view %s
238cdf0e10cSrcweirapplication/x-wordperfect; %unixfilename -view %s
239cdf0e10cSrcweirapplication/wordperfect; %unixfilename -view %s
240cdf0e10cSrcweirapplication/wpwin; %unixfilename -view %s
241cdf0e10cSrcweirapplication/vnd.openofficeorg.extension; %unixfilename %s
242cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.wordprocessingml.document; %unixfilename -view %s
243cdf0e10cSrcweirapplication/vnd.ms-word.document.macroenabled.12;%unixfilename -view %s
244cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.wordprocessingml.template; %unixfilename -view %s
245cdf0e10cSrcweirapplication/vnd.ms-word.template.macroenabled.12; %unixfilename -view %s
246cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.spreadsheetml.sheet; %unixfilename -view %s
247cdf0e10cSrcweirapplication/vnd.ms-excel.sheet.macroenabled.12; %unixfilename -view %s
248cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.spreadsheetml.template; %unixfilename -view %s
249cdf0e10cSrcweirapplication/vnd.ms-excel.template.macroenabled.12; %unixfilename -view %s
250cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.presentationml.presentation; %unixfilename -view %s
251cdf0e10cSrcweirapplication/vnd.ms-powerpoint.presentation.macroenabled.12; %unixfilename -view %s
252cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.presentationml.template; %unixfilename -view %s
253cdf0e10cSrcweirapplication/vnd.ms-powerpoint.template.macroenabled.12; %unixfilename -view %s
254cdf0e10cSrcweirEND
255cdf0e10cSrcweir
256cdf0e10cSrcweir  # and replace the original file
257cdf0e10cSrcweir  mv -f /etc/mailcap.tmp$$ /etc/mailcap
258cdf0e10cSrcweirfi
259cdf0e10cSrcweir
260cdf0e10cSrcweir%preun
261cdf0e10cSrcweir# remove from /etc/mailcap only on de-install
262cdf0e10cSrcweirif [ "$1" = 0 ]
263cdf0e10cSrcweirthen
264cdf0e10cSrcweir  # backing all entries pointing to our binary
265cdf0e10cSrcweir  sed '/%unixfilename/d' /etc/mailcap 2>/dev/null >> /etc/mailcap.tmp$$
266cdf0e10cSrcweir
267cdf0e10cSrcweir  # and replace the original file
268cdf0e10cSrcweir  mv -f /etc/mailcap.tmp$$ /etc/mailcap
269cdf0e10cSrcweirfi
270cdf0e10cSrcweir
271cdf0e10cSrcweir%postun
272cdf0e10cSrcweir# run only when erasing this package, since %post of the new package ran
273cdf0e10cSrcweir# previously or updates already handled by triggers.
274cdf0e10cSrcweirif [ "$1" = 0 ] ; then
275cdf0e10cSrcweir  if [ -x /usr/bin/update-desktop-database ]; then
276cdf0e10cSrcweir    update-desktop-database -q /usr/share/applications
277cdf0e10cSrcweir  fi
278cdf0e10cSrcweir  if [ -x /usr/bin/update-mime-database ]; then
279cdf0e10cSrcweir    update-mime-database /usr/share/mime
280cdf0e10cSrcweir  fi
281cdf0e10cSrcweirfi
282cdf0e10cSrcweir#run always
283cdf0e10cSrcweirfor theme in gnome hicolor locolor; do
284cdf0e10cSrcweir  if [ -e /usr/share/icons/$theme/icon-theme.cache ] ; then
285cdf0e10cSrcweir    # touch it, just in case we cannot find the binary...
286cdf0e10cSrcweir    touch /usr/share/icons/$theme
287cdf0e10cSrcweir    if (which gtk-update-icon-cache); then
288cdf0e10cSrcweir      gtk-update-icon-cache /usr/share/icons/$theme
289cdf0e10cSrcweir    fi
290cdf0e10cSrcweir    # ignore errors (e.g. when there is a cache, but no index.theme)
291cdf0e10cSrcweir    true
292cdf0e10cSrcweir  fi
293cdf0e10cSrcweirdone
294cdf0e10cSrcweir
295cdf0e10cSrcweir%files
296cdf0e10cSrcweir%attr(0755,root,root) /usr/bin/soffice
297cdf0e10cSrcweir%attr(0755,root,root) %verify(not size md5) /usr/bin/%unixfilename
298cdf0e10cSrcweir%attr(0755,root,root) /usr/bin/%unixfilename-printeradmin
299cdf0e10cSrcweir%defattr(0644, root, root)
300cdf0e10cSrcweir/usr/share/application-registry/*.applications
301cdf0e10cSrcweir/usr/share/applications/%unixfilename-writer.desktop
302cdf0e10cSrcweir/usr/share/applications/%unixfilename-calc.desktop
303cdf0e10cSrcweir/usr/share/applications/%unixfilename-draw.desktop
304cdf0e10cSrcweir/usr/share/applications/%unixfilename-impress.desktop
305cdf0e10cSrcweir/usr/share/applications/%unixfilename-math.desktop
306cdf0e10cSrcweir/usr/share/applications/%unixfilename-base.desktop
307cdf0e10cSrcweir/usr/share/applications/%unixfilename-printeradmin.desktop
308cdf0e10cSrcweir/usr/share/applications/%unixfilename-startcenter.desktop
309cdf0e10cSrcweir/usr/share/applications/%unixfilename-javafilter.desktop
310cdf0e10cSrcweir/usr/share/applnk-redhat/Office/%unixfilename-writer.desktop
311cdf0e10cSrcweir/usr/share/applnk-redhat/Office/%unixfilename-calc.desktop
312cdf0e10cSrcweir/usr/share/applnk-redhat/Office/%unixfilename-draw.desktop
313cdf0e10cSrcweir/usr/share/applnk-redhat/Office/%unixfilename-impress.desktop
314cdf0e10cSrcweir/usr/share/applnk-redhat/Office/%unixfilename-math.desktop
315cdf0e10cSrcweir/usr/share/applnk-redhat/Office/%unixfilename-base.desktop
316cdf0e10cSrcweir/usr/share/applnk-redhat/Office/%unixfilename-printeradmin.desktop
317cdf0e10cSrcweir/usr/share/applnk-redhat/Office/%unixfilename-startcenter.desktop
318cdf0e10cSrcweir/usr/share/applnk-redhat/Office/%unixfilename-javafilter.desktop
319cdf0e10cSrcweir/usr/share/mime-info/*.keys
320cdf0e10cSrcweir/usr/share/mime-info/*.mime
321cdf0e10cSrcweir/usr/share/mimelnk/application/*.desktop
322cdf0e10cSrcweir/usr/share/icons/gnome/*/apps/*png
323cdf0e10cSrcweir/usr/share/icons/gnome/*/mimetypes/*png
324cdf0e10cSrcweir/usr/share/icons/hicolor/*/apps/*png
325cdf0e10cSrcweir/usr/share/icons/hicolor/*/mimetypes/*png
326cdf0e10cSrcweir/usr/share/icons/locolor/*/apps/*png
327cdf0e10cSrcweir/usr/share/icons/locolor/*/mimetypes/*png
328cdf0e10cSrcweir/usr/share/mime/packages/*
329