xref: /aoo41x/main/package/util/makefile.mk (revision 7871dc3e)
1*7871dc3eSAndrew Rist#**************************************************************
2*7871dc3eSAndrew Rist#
3*7871dc3eSAndrew Rist#  Licensed to the Apache Software Foundation (ASF) under one
4*7871dc3eSAndrew Rist#  or more contributor license agreements.  See the NOTICE file
5*7871dc3eSAndrew Rist#  distributed with this work for additional information
6*7871dc3eSAndrew Rist#  regarding copyright ownership.  The ASF licenses this file
7*7871dc3eSAndrew Rist#  to you under the Apache License, Version 2.0 (the
8*7871dc3eSAndrew Rist#  "License"); you may not use this file except in compliance
9*7871dc3eSAndrew Rist#  with the License.  You may obtain a copy of the License at
10*7871dc3eSAndrew Rist#
11*7871dc3eSAndrew Rist#    http://www.apache.org/licenses/LICENSE-2.0
12*7871dc3eSAndrew Rist#
13*7871dc3eSAndrew Rist#  Unless required by applicable law or agreed to in writing,
14*7871dc3eSAndrew Rist#  software distributed under the License is distributed on an
15*7871dc3eSAndrew Rist#  "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
16*7871dc3eSAndrew Rist#  KIND, either express or implied.  See the License for the
17*7871dc3eSAndrew Rist#  specific language governing permissions and limitations
18*7871dc3eSAndrew Rist#  under the License.
19*7871dc3eSAndrew Rist#
20*7871dc3eSAndrew Rist#**************************************************************
21*7871dc3eSAndrew Rist
22*7871dc3eSAndrew Rist
23cdf0e10cSrcweir
24cdf0e10cSrcweir# 2 == Unicode
25cdf0e10cSrcweirMAJOR_VERSION=2
26cdf0e10cSrcweir
27cdf0e10cSrcweirPRJ=..
28cdf0e10cSrcweirPRJNAME=package
29cdf0e10cSrcweirTARGET=package
30cdf0e10cSrcweir
31cdf0e10cSrcweirENABLE_EXCEPTIONS=TRUE
32cdf0e10cSrcweirUSE_DEFFILE=TRUE
33cdf0e10cSrcweirNO_BSYMBOLIC=TRUE
34cdf0e10cSrcweir
35cdf0e10cSrcweir
36cdf0e10cSrcweir# --- Settings -----------------------------------------------------
37cdf0e10cSrcweir
38cdf0e10cSrcweir.INCLUDE :  settings.mk
39cdf0e10cSrcweir
40cdf0e10cSrcweir.IF "$(L10N_framework)"==""
41cdf0e10cSrcweir
42cdf0e10cSrcweir# --- General ----------------------------------------------------
43cdf0e10cSrcweir
44cdf0e10cSrcweirLIB1TARGET= $(SLB)$/$(TARGET).lib
45cdf0e10cSrcweirLIB1FILES=	\
46cdf0e10cSrcweir    $(SLB)$/zipapi.lib \
47cdf0e10cSrcweir    $(SLB)$/zippackage.lib \
48cdf0e10cSrcweir    $(SLB)$/manifest.lib
49cdf0e10cSrcweir
50cdf0e10cSrcweir# --- Shared-Library -----------------------------------------------
51cdf0e10cSrcweir
52cdf0e10cSrcweirSHL1TARGET=$(TARGET)$(MAJOR_VERSION)
53cdf0e10cSrcweirSHL1IMPLIB=i$(TARGET)
54cdf0e10cSrcweirSHL1VERSIONMAP=$(SOLARENV)$/src$/component.map
55cdf0e10cSrcweir
56cdf0e10cSrcweirSHL1STDLIBS=\
57cdf0e10cSrcweir	$(CPPULIB)		\
58cdf0e10cSrcweir	$(UCBHELPERLIB)		\
59cdf0e10cSrcweir	$(CPPUHELPERLIB)	\
60cdf0e10cSrcweir	$(COMPHELPERLIB)		\
61cdf0e10cSrcweir	$(SALLIB)		\
62cdf0e10cSrcweir	$(ZLIB3RDLIB)
63cdf0e10cSrcweir
64cdf0e10cSrcweirSHL1DEF=$(MISC)$/$(SHL1TARGET).def
65cdf0e10cSrcweirSHL1LIBS=$(LIB1TARGET)
66cdf0e10cSrcweirDEF1NAME=$(SHL1TARGET)
67cdf0e10cSrcweir
68cdf0e10cSrcweir.ENDIF # L10N_framework
69cdf0e10cSrcweir
70cdf0e10cSrcweir# --- Targets ----------------------------------------------------------
71cdf0e10cSrcweir
72cdf0e10cSrcweir.INCLUDE :  target.mk
73cdf0e10cSrcweir
74cdf0e10cSrcweir
75cdf0e10cSrcweirALLTAR : $(MISC)/package2.component
76cdf0e10cSrcweir
77cdf0e10cSrcweir$(MISC)/package2.component .ERRREMOVE : $(SOLARENV)/bin/createcomponent.xslt \
78cdf0e10cSrcweir        package2.component
79cdf0e10cSrcweir    $(XSLTPROC) --nonet --stringparam uri \
80cdf0e10cSrcweir        '$(COMPONENTPREFIX_BASIS_NATIVE)$(SHL1TARGETN:f)' -o $@ \
81cdf0e10cSrcweir        $(SOLARENV)/bin/createcomponent.xslt package2.component
82