xref: /aoo41x/main/package/util/makefile.mk (revision cdf0e10c)
1*cdf0e10cSrcweir#*************************************************************************
2*cdf0e10cSrcweir#
3*cdf0e10cSrcweir# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
4*cdf0e10cSrcweir#
5*cdf0e10cSrcweir# Copyright 2000, 2010 Oracle and/or its affiliates.
6*cdf0e10cSrcweir#
7*cdf0e10cSrcweir# OpenOffice.org - a multi-platform office productivity suite
8*cdf0e10cSrcweir#
9*cdf0e10cSrcweir# This file is part of OpenOffice.org.
10*cdf0e10cSrcweir#
11*cdf0e10cSrcweir# OpenOffice.org is free software: you can redistribute it and/or modify
12*cdf0e10cSrcweir# it under the terms of the GNU Lesser General Public License version 3
13*cdf0e10cSrcweir# only, as published by the Free Software Foundation.
14*cdf0e10cSrcweir#
15*cdf0e10cSrcweir# OpenOffice.org is distributed in the hope that it will be useful,
16*cdf0e10cSrcweir# but WITHOUT ANY WARRANTY; without even the implied warranty of
17*cdf0e10cSrcweir# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
18*cdf0e10cSrcweir# GNU Lesser General Public License version 3 for more details
19*cdf0e10cSrcweir# (a copy is included in the LICENSE file that accompanied this code).
20*cdf0e10cSrcweir#
21*cdf0e10cSrcweir# You should have received a copy of the GNU Lesser General Public License
22*cdf0e10cSrcweir# version 3 along with OpenOffice.org.  If not, see
23*cdf0e10cSrcweir# <http://www.openoffice.org/license.html>
24*cdf0e10cSrcweir# for a copy of the LGPLv3 License.
25*cdf0e10cSrcweir#
26*cdf0e10cSrcweir#*************************************************************************
27*cdf0e10cSrcweir
28*cdf0e10cSrcweir# 2 == Unicode
29*cdf0e10cSrcweirMAJOR_VERSION=2
30*cdf0e10cSrcweir
31*cdf0e10cSrcweirPRJ=..
32*cdf0e10cSrcweirPRJNAME=package
33*cdf0e10cSrcweirTARGET=package
34*cdf0e10cSrcweir
35*cdf0e10cSrcweirENABLE_EXCEPTIONS=TRUE
36*cdf0e10cSrcweirUSE_DEFFILE=TRUE
37*cdf0e10cSrcweirNO_BSYMBOLIC=TRUE
38*cdf0e10cSrcweir
39*cdf0e10cSrcweir
40*cdf0e10cSrcweir# --- Settings -----------------------------------------------------
41*cdf0e10cSrcweir
42*cdf0e10cSrcweir.INCLUDE :  settings.mk
43*cdf0e10cSrcweir
44*cdf0e10cSrcweir.IF "$(L10N_framework)"==""
45*cdf0e10cSrcweir
46*cdf0e10cSrcweir# --- General ----------------------------------------------------
47*cdf0e10cSrcweir
48*cdf0e10cSrcweirLIB1TARGET= $(SLB)$/$(TARGET).lib
49*cdf0e10cSrcweirLIB1FILES=	\
50*cdf0e10cSrcweir    $(SLB)$/zipapi.lib \
51*cdf0e10cSrcweir    $(SLB)$/zippackage.lib \
52*cdf0e10cSrcweir    $(SLB)$/manifest.lib
53*cdf0e10cSrcweir
54*cdf0e10cSrcweir# --- Shared-Library -----------------------------------------------
55*cdf0e10cSrcweir
56*cdf0e10cSrcweirSHL1TARGET=$(TARGET)$(MAJOR_VERSION)
57*cdf0e10cSrcweirSHL1IMPLIB=i$(TARGET)
58*cdf0e10cSrcweirSHL1VERSIONMAP=$(SOLARENV)$/src$/component.map
59*cdf0e10cSrcweir
60*cdf0e10cSrcweirSHL1STDLIBS=\
61*cdf0e10cSrcweir	$(CPPULIB)		\
62*cdf0e10cSrcweir	$(UCBHELPERLIB)		\
63*cdf0e10cSrcweir	$(CPPUHELPERLIB)	\
64*cdf0e10cSrcweir	$(COMPHELPERLIB)		\
65*cdf0e10cSrcweir	$(SALLIB)		\
66*cdf0e10cSrcweir	$(ZLIB3RDLIB)
67*cdf0e10cSrcweir
68*cdf0e10cSrcweirSHL1DEF=$(MISC)$/$(SHL1TARGET).def
69*cdf0e10cSrcweirSHL1LIBS=$(LIB1TARGET)
70*cdf0e10cSrcweirDEF1NAME=$(SHL1TARGET)
71*cdf0e10cSrcweir
72*cdf0e10cSrcweir.ENDIF # L10N_framework
73*cdf0e10cSrcweir
74*cdf0e10cSrcweir# --- Targets ----------------------------------------------------------
75*cdf0e10cSrcweir
76*cdf0e10cSrcweir.INCLUDE :  target.mk
77*cdf0e10cSrcweir
78*cdf0e10cSrcweir
79*cdf0e10cSrcweirALLTAR : $(MISC)/package2.component
80*cdf0e10cSrcweir
81*cdf0e10cSrcweir$(MISC)/package2.component .ERRREMOVE : $(SOLARENV)/bin/createcomponent.xslt \
82*cdf0e10cSrcweir        package2.component
83*cdf0e10cSrcweir    $(XSLTPROC) --nonet --stringparam uri \
84*cdf0e10cSrcweir        '$(COMPONENTPREFIX_BASIS_NATIVE)$(SHL1TARGETN:f)' -o $@ \
85*cdf0e10cSrcweir        $(SOLARENV)/bin/createcomponent.xslt package2.component
86