1cdf0e10cSrcweir# version and release passed by command-line
2cdf0e10cSrcweirVersion: %version
3cdf0e10cSrcweirRelease: %release
4cdf0e10cSrcweirSummary: %productname desktop integration
5cdf0e10cSrcweirName: %pkgprefix-freedesktop-menus
6cdf0e10cSrcweir#BuildRequires: sed
7cdf0e10cSrcweir#BuildRequires: perl
8cdf0e10cSrcweirGroup: Office
9*bda541ebSArmin Le GrandLicense: ALv2
10cdf0e10cSrcweirProvides: openoffice.org3-desktop-integration
11cdf0e10cSrcweirConflicts: %pkgprefix-suse-menus
12cdf0e10cSrcweirConflicts: %pkgprefix-debian-menus
13cdf0e10cSrcweirConflicts: %pkgprefix-redhat-menus
14cdf0e10cSrcweirConflicts: %pkgprefix-mandriva-menus
15cdf0e10cSrcweirBuildArch: noarch
16cdf0e10cSrcweirAutoReqProv: no
17cdf0e10cSrcweir%define _binary_filedigest_algorithm 1
18cdf0e10cSrcweir%define _binary_payload w9.gzdio
19cdf0e10cSrcweir
20cdf0e10cSrcweir%description
21cdf0e10cSrcweir%productname desktop integration for desktop-environments that implement
22cdf0e10cSrcweirthe menu- and mime-related specifications from http://www.freedesktop.org
23cdf0e10cSrcweirInstall this package if you're using a distribution not covered by any of
24cdf0e10cSrcweirthe other %pkgprefix-<distribution>-menus packages.
25cdf0e10cSrcweir
26cdf0e10cSrcweir%install
27cdf0e10cSrcweirrm -rf $RPM_BUILD_ROOT
28cdf0e10cSrcweir
29cdf0e10cSrcweir# hack/workaround to make SuSE's brp-symlink-script happy. It wants the targets of all links
30cdf0e10cSrcweir# to be present on the build-system/the buildroot. But the point is that we generate stale
31cdf0e10cSrcweir# links intentionally (until we find a better solution) #46226
32cdf0e10cSrcweirexport NO_BRP_STALE_LINK_ERROR=yes
33cdf0e10cSrcweir
34cdf0e10cSrcweirmkdir -p $RPM_BUILD_ROOT
35cdf0e10cSrcweir
36cdf0e10cSrcweir# FIXME: remove - only purpose is to create packages identical to OOF680 m8
37cdf0e10cSrcweirumask 0000
38cdf0e10cSrcweir
39cdf0e10cSrcweir# set parameters for the create_tree script
40cdf0e10cSrcweirexport DESTDIR=$RPM_BUILD_ROOT
41cdf0e10cSrcweirexport KDEMAINDIR=/usr
42cdf0e10cSrcweirexport GNOMEDIR=/usr
43cdf0e10cSrcweirexport GNOME_MIME_THEME=hicolor
44cdf0e10cSrcweir
45cdf0e10cSrcweir./create_tree.sh
46cdf0e10cSrcweir
47cdf0e10cSrcweircd $RPM_BUILD_ROOT
48cdf0e10cSrcweir
49cdf0e10cSrcweir# freedesktop-based desktop-environments don't need/use this.
50cdf0e10cSrcweirrm -rf usr/share/application-registry
51cdf0e10cSrcweirrm -rf usr/share/applications.flag
52cdf0e10cSrcweirrm -rf usr/share/mime-info
53cdf0e10cSrcweirrm -rf usr/share/mimelnk
54cdf0e10cSrcweirrm -rf usr/share/applnk-redhat
55cdf0e10cSrcweir#find usr/share/icons -name '*.png' -exec chmod g+w {} \;
56cdf0e10cSrcweir
57cdf0e10cSrcweir%clean
58cdf0e10cSrcweirrm -rf $RPM_BUILD_ROOT
59cdf0e10cSrcweir
60cdf0e10cSrcweir%triggerin -- %pkgprefix, %pkgprefix-writer, %pkgprefix-calc, %pkgprefix-draw, %pkgprefix-impress, %pkgprefix-math
61cdf0e10cSrcweir# this is run when one of the above packages is already installed and the menu
62cdf0e10cSrcweir# package gets installed OR when the menu-package is already installed and one
63cdf0e10cSrcweir# of the above listed packages gets installed
64cdf0e10cSrcweir
65cdf0e10cSrcweir# Dut to a bug in rpm it is not possible to check why the script is triggered...
66cdf0e10cSrcweir# This is how it should be: 1st arg: number of this package, 2nd arg: number of
67cdf0e10cSrcweir# package that triggers - the bug is that rpm reports the same number for both
68cdf0e10cSrcweir# (the value of the 2nd one), so just run this always...
69cdf0e10cSrcweir# http://rhn.redhat.com/errata/RHBA-2004-098.html
70cdf0e10cSrcweir# https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=100509
71cdf0e10cSrcweir
72cdf0e10cSrcweirif [ -x /opt/gnome/bin/update-desktop-database ]; then
73cdf0e10cSrcweir    /opt/gnome/bin/update-desktop-database -q
74cdf0e10cSrcweirelif (which update-desktop-database); then
75cdf0e10cSrcweir  update-desktop-database -q /usr/share/applications
76cdf0e10cSrcweirfi
77cdf0e10cSrcweir
78cdf0e10cSrcweir%triggerun -- %pkgprefix, %pkgprefix-writer, %pkgprefix-calc, %pkgprefix-draw, %pkgprefix-impress, %pkgprefix-math
79cdf0e10cSrcweirif [ "$1" = "0" ] ; then
80cdf0e10cSrcweir  # the menu-package gets uninstalled/updated - postun will run the command
81cdf0e10cSrcweir  exit 0
82cdf0e10cSrcweirfi
83cdf0e10cSrcweirif [ "$2" = "0" ] ; then
84cdf0e10cSrcweir  # the triggering package gets removed
85cdf0e10cSrcweir  if [ -x /opt/gnome/bin/update-desktop-database ]; then
86cdf0e10cSrcweir      /opt/gnome/bin/update-desktop-database -q
87cdf0e10cSrcweir  elif (which update-desktop-database); then
88cdf0e10cSrcweir    update-desktop-database -q /usr/share/applications
89cdf0e10cSrcweir  fi
90cdf0e10cSrcweirfi
91cdf0e10cSrcweir
92cdf0e10cSrcweir%post
93cdf0e10cSrcweir# no need to run it when updating, since %postun of the old package is run
94cdf0e10cSrcweir# afterwards
95cdf0e10cSrcweir
96cdf0e10cSrcweirif [ "$1" = "1" ] ; then  # first install
97cdf0e10cSrcweir  if [ -x /opt/gnome/bin/update-desktop-database ]; then
98cdf0e10cSrcweir    /opt/gnome/bin/update-desktop-database -q
99cdf0e10cSrcweir  elif (which update-desktop-database); then
100cdf0e10cSrcweir    update-desktop-database -q /usr/share/applications
101cdf0e10cSrcweir  fi
102cdf0e10cSrcweir
103cdf0e10cSrcweir  if (which update-mime-database); then
104cdf0e10cSrcweir    update-mime-database /usr/share/mime
105cdf0e10cSrcweir  fi
106cdf0e10cSrcweirfi
107cdf0e10cSrcweir
108cdf0e10cSrcweir
109cdf0e10cSrcweir#run always
110cdf0e10cSrcweirfor theme in gnome hicolor locolor; do
111cdf0e10cSrcweir    if [ -e /usr/share/icons/$theme/icon-theme.cache ] ; then
112cdf0e10cSrcweir        # touch it, just in case we cannot find the binary...
113cdf0e10cSrcweir        touch /usr/share/icons/$theme
114cdf0e10cSrcweir        if [ -x /opt/gnome/bin/gtk-update-icon-cache ]; then
115cdf0e10cSrcweir            /opt/gnome/bin/gtk-update-icon-cache -q /usr/share/icons/$theme
116cdf0e10cSrcweir        elif (which gtk-update-icon-cache); then
117cdf0e10cSrcweir            gtk-update-icon-cache -q /usr/share/icons/$theme
118cdf0e10cSrcweir        fi
119cdf0e10cSrcweir        # ignore errors (e.g. when there is a cache, but no index.theme)
120cdf0e10cSrcweir        true
121cdf0e10cSrcweir    fi
122cdf0e10cSrcweirdone
123cdf0e10cSrcweir
124cdf0e10cSrcweir
125cdf0e10cSrcweir# update /etc/mime.types
126cdf0e10cSrcweir# backing out existing entries to avoid duplicates
127cdf0e10cSrcweirsed '
128cdf0e10cSrcweir/application\/vnd\.oasis\.opendocument/d
129cdf0e10cSrcweir/application\/vnd\.sun/d
130cdf0e10cSrcweir/application\/vnd\.stardivision/d
131cdf0e10cSrcweir/application\/vnd\.openofficeorg/d
132cdf0e10cSrcweir' /etc/mime.types 2>/dev/null >> /etc/mime.types.tmp$$
133cdf0e10cSrcweir
134cdf0e10cSrcweir# now append our stuff to the temporary file
135cdf0e10cSrcweircat >> /etc/mime.types.tmp$$ << END
136cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text	odt
137cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-template ott
138cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-web oth
139cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-master odm
140cdf0e10cSrcweirapplication/vnd.oasis.opendocument.graphics odg
141cdf0e10cSrcweirapplication/vnd.oasis.opendocument.graphics-template otg
142cdf0e10cSrcweirapplication/vnd.oasis.opendocument.presentation odp
143cdf0e10cSrcweirapplication/vnd.oasis.opendocument.presentation-template otp
144cdf0e10cSrcweirapplication/vnd.oasis.opendocument.spreadsheet ods
145cdf0e10cSrcweirapplication/vnd.oasis.opendocument.spreadsheet-template ots
146cdf0e10cSrcweirapplication/vnd.oasis.opendocument.chart odc
147cdf0e10cSrcweirapplication/vnd.oasis.opendocument.formula odf
148cdf0e10cSrcweirapplication/vnd.oasis.opendocument.image odi
149cdf0e10cSrcweirapplication/vnd.sun.xml.writer sxw
150cdf0e10cSrcweirapplication/vnd.sun.xml.writer.template stw
151cdf0e10cSrcweirapplication/vnd.sun.xml.writer.global sxg
152cdf0e10cSrcweirapplication/vnd.stardivision.writer sdw vor
153cdf0e10cSrcweirapplication/vnd.stardivision.writer-global sgl
154cdf0e10cSrcweirapplication/vnd.sun.xml.calc sxc
155cdf0e10cSrcweirapplication/vnd.sun.xml.calc.template stc
156cdf0e10cSrcweirapplication/vnd.stardivision.calc sdc
157cdf0e10cSrcweirapplication/vnd.stardivision.chart sds
158cdf0e10cSrcweirapplication/vnd.sun.xml.impress sxi
159cdf0e10cSrcweirapplication/vnd.sun.xml.impress.template sti
160cdf0e10cSrcweirapplication/vnd.stardivision.impress sdd sdp
161cdf0e10cSrcweirapplication/vnd.sun.xml.draw sxd
162cdf0e10cSrcweirapplication/vnd.sun.xml.draw.template std
163cdf0e10cSrcweirapplication/vnd.stardivision.draw sda
164cdf0e10cSrcweirapplication/vnd.sun.xml.math sxm
165cdf0e10cSrcweirapplication/vnd.sun.xml.base odb
166cdf0e10cSrcweirapplication/vnd.stardivision.math smf
167cdf0e10cSrcweirapplication/vnd.openofficeorg.extension oxt
168cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.wordprocessingml.document docx
169cdf0e10cSrcweirapplication/vnd.ms-word.document.macroenabled.12 docm
170cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.wordprocessingml.template dotx
171cdf0e10cSrcweirapplication/vnd.ms-word.template.macroenabled.12 dotm
172cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.spreadsheetml.sheet xlsx
173cdf0e10cSrcweirapplication/vnd.ms-excel.sheet.macroenabled.12 xlsm
174cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.spreadsheetml.template xltx
175cdf0e10cSrcweirapplication/vnd.ms-excel.template.macroenabled.12 xltm
176cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.presentationml.presentation pptx
177cdf0e10cSrcweirapplication/vnd.ms-powerpoint.presentation.macroenabled.12 pptm
178cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.presentationml.template potx
179cdf0e10cSrcweirapplication/vnd.ms-powerpoint.template.macroenabled.12 potm
180cdf0e10cSrcweirEND
181cdf0e10cSrcweir
182cdf0e10cSrcweir# and replace the original file
183cdf0e10cSrcweirmv -f /etc/mime.types.tmp$$ /etc/mime.types 2>/dev/null
184cdf0e10cSrcweir
185cdf0e10cSrcweir# update /etc/mailcap only at initial install
186cdf0e10cSrcweirif [ "$1" = 1 ]
187cdf0e10cSrcweirthen
188cdf0e10cSrcweir  # backing out existing entries to avoid duplicates
189cdf0e10cSrcweir  sed '
190cdf0e10cSrcweir/^# OpenOffice.org/d
191cdf0e10cSrcweir/^application\/vnd\.oasis\.opendocument/d
192cdf0e10cSrcweir/^application\/vnd\.openofficeorg/d
193cdf0e10cSrcweir/^application\/vnd\.sun/d
194cdf0e10cSrcweir/^application\/vnd\.stardivision/d
195cdf0e10cSrcweir/^application\/vnd\.ms-word/d
196cdf0e10cSrcweir/^application\/vnd\.ms-excel/d
197cdf0e10cSrcweir/^application\/vnd\.ms-powerpoint/d
198cdf0e10cSrcweir/^application\/x-star/d
199cdf0e10cSrcweir/excel/d
200cdf0e10cSrcweir/ms[-]*word/d
201cdf0e10cSrcweir/powerpoint/d
202cdf0e10cSrcweir' /etc/mailcap 2>/dev/null >> /etc/mailcap.tmp$$
203cdf0e10cSrcweir
204cdf0e10cSrcweir  # now append our stuff to the temporary file
205cdf0e10cSrcweir  cat >> /etc/mailcap.tmp$$ << END
206*bda541ebSArmin Le Grand# Apache OpenOffice
207cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text; %unixfilename -view %s
208cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-template; %unixfilename -view %s
209cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-web; %unixfilename -view %s
210cdf0e10cSrcweirapplication/vnd.oasis.opendocument.text-master; %unixfilename -view %s
211cdf0e10cSrcweirapplication/vnd.sun.xml.writer; %unixfilename -view %s
212cdf0e10cSrcweirapplication/vnd.sun.xml.writer.template; %unixfilename -view %s
213cdf0e10cSrcweirapplication/vnd.sun.xml.writer.global; %unixfilename -view %s
214cdf0e10cSrcweirapplication/vnd.stardivision.writer; %unixfilename -view %s
215cdf0e10cSrcweirapplication/vnd.stardivision.writer-global; %unixfilename -view %s
216cdf0e10cSrcweirapplication/x-starwriter; %unixfilename -view %s
217cdf0e10cSrcweirapplication/vnd.oasis.opendocument.formula; %unixfilename -view %s
218cdf0e10cSrcweirapplication/vnd.sun.xml.math; %unixfilename -view %s
219cdf0e10cSrcweirapplication/vnd.stardivision.math; %unixfilename -view %s
220cdf0e10cSrcweirapplication/x-starmath; %unixfilename -view %s
221cdf0e10cSrcweirapplication/msword; %unixfilename -view %s
222cdf0e10cSrcweirapplication/vnd.oasis.opendocument.spreadsheet; %unixfilename -view %s
223cdf0e10cSrcweirapplication/vnd.oasis.opendocument.spreadsheet-template; %unixfilename -view %s
224cdf0e10cSrcweirapplication/vnd.sun.xml.calc; %unixfilename -view %s
225cdf0e10cSrcweirapplication/vnd.sun.xml.calc.template; %unixfilename -view %s
226cdf0e10cSrcweirapplication/vnd.stardivision.calc; %unixfilename -view %s
227cdf0e10cSrcweirapplication/x-starcalc; %unixfilename -view %s
228cdf0e10cSrcweirapplication/vnd.stardivision.chart; %unixfilename -view %s
229cdf0e10cSrcweirapplication/x-starchart; %unixfilename -view %s
230cdf0e10cSrcweirapplication/excel; %unixfilename -view %s
231cdf0e10cSrcweirapplication/msexcel; %unixfilename -view %s
232cdf0e10cSrcweirapplication/vnd.ms-excel; %unixfilename -view %s
233cdf0e10cSrcweirapplication/x-msexcel; %unixfilename -view %s
234cdf0e10cSrcweirapplication/vnd.oasis.opendocument.presentation; %unixfilename -view %s
235cdf0e10cSrcweirapplication/vnd.oasis.opendocument.presentation-template; %unixfilename -view %s
236cdf0e10cSrcweirapplication/vnd.sun.xml.impress; %unixfilename -view %s
237cdf0e10cSrcweirapplication/vnd.sun.xml.impress.template; %unixfilename -view %s
238cdf0e10cSrcweirapplication/vnd.stardivision.impress; %unixfilename -view %s
239cdf0e10cSrcweirapplication/x-starimpress; %unixfilename -view %s
240cdf0e10cSrcweirapplication/powerpoint; %unixfilename -view %s
241cdf0e10cSrcweirapplication/mspowerpoint; %unixfilename -view %s
242cdf0e10cSrcweirapplication/vnd.ms-powerpoint; %unixfilename -view %s
243cdf0e10cSrcweirapplication/x-mspowerpoint; %unixfilename -view %s
244cdf0e10cSrcweirapplication/vnd.oasis.opendocument.graphics; %unixfilename -view %s
245cdf0e10cSrcweirapplication/vnd.oasis.opendocument.graphics-template; %unixfilename -view %s
246cdf0e10cSrcweirapplication/vnd.sun.xml.draw; %unixfilename -view %s
247cdf0e10cSrcweirapplication/vnd.sun.xml.draw.template; %unixfilename -view %s
248cdf0e10cSrcweirapplication/vnd.stardivision.draw; %unixfilename -view %s
249cdf0e10cSrcweirapplication/x-stardraw; %unixfilename -view %s
250cdf0e10cSrcweirapplication/vnd.oasis.opendocument.database; %unixfilename -view %s
251cdf0e10cSrcweirapplication/vnd.sun.xml.base; %unixfilename -view %s
252cdf0e10cSrcweirapplication/vnd.openofficeorg.extension; %unixfilename %s
253cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.wordprocessingml.document; %unixfilename -view %s
254cdf0e10cSrcweirapplication/vnd.ms-word.document.macroenabled.12;%unixfilename -view %s
255cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.wordprocessingml.template; %unixfilename -view %s
256cdf0e10cSrcweirapplication/vnd.ms-word.template.macroenabled.12; %unixfilename -view %s
257cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.spreadsheetml.sheet; %unixfilename -view %s
258cdf0e10cSrcweirapplication/vnd.ms-excel.sheet.macroenabled.12; %unixfilename -view %s
259cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.spreadsheetml.template; %unixfilename -view %s
260cdf0e10cSrcweirapplication/vnd.ms-excel.template.macroenabled.12; %unixfilename -view %s
261cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.presentationml.presentation; %unixfilename -view %s
262cdf0e10cSrcweirapplication/vnd.ms-powerpoint.presentation.macroenabled.12; %unixfilename -view %s
263cdf0e10cSrcweirapplication/vnd.openxmlformats-officedocument.presentationml.template; %unixfilename -view %s
264cdf0e10cSrcweirapplication/vnd.ms-powerpoint.template.macroenabled.12; %unixfilename -view %s
265cdf0e10cSrcweirEND
266cdf0e10cSrcweir
267cdf0e10cSrcweir  # and replace the original file
268cdf0e10cSrcweir  mv -f /etc/mailcap.tmp$$ /etc/mailcap
269cdf0e10cSrcweirfi
270cdf0e10cSrcweir
271cdf0e10cSrcweirif [ -x /opt/gnome/bin/update-desktop-database ]; then
272cdf0e10cSrcweir    /opt/gnome/bin/update-desktop-database -q
273cdf0e10cSrcweirelif (which update-desktop-database); then
274cdf0e10cSrcweir  update-desktop-database -q /usr/share/applications
275cdf0e10cSrcweirfi
276cdf0e10cSrcweir
277cdf0e10cSrcweir%preun
278cdf0e10cSrcweir# remove from /etc/mailcap only on de-install
279cdf0e10cSrcweirif [ "$1" = 0 ]
280cdf0e10cSrcweirthen
281cdf0e10cSrcweir  # backing all entries pointing to our binary
282cdf0e10cSrcweir  sed '/%unixfilename/d' /etc/mailcap 2>/dev/null >> /etc/mailcap.tmp$$
283cdf0e10cSrcweir
284cdf0e10cSrcweir  # and replace the original file
285cdf0e10cSrcweir  mv -f /etc/mailcap.tmp$$ /etc/mailcap
286cdf0e10cSrcweirfi
287cdf0e10cSrcweir
288cdf0e10cSrcweir%postun
289cdf0e10cSrcweirif [ "$1" = 0 ] ; then # only run when erasing the package - other cases handled by the triggers
290cdf0e10cSrcweir  if [ -x /opt/gnome/bin/update-desktop-database ]; then
291cdf0e10cSrcweir    /opt/gnome/bin/update-desktop-database -q
292cdf0e10cSrcweir  elif (which update-desktop-database); then
293cdf0e10cSrcweir    update-desktop-database -q
294cdf0e10cSrcweir  fi
295cdf0e10cSrcweir# run always - both when upgrading as well as when erasing the package
296cdf0e10cSrcweir  if (which update-mime-database); then
297cdf0e10cSrcweir    update-mime-database /usr/share/mime
298cdf0e10cSrcweir  fi
299cdf0e10cSrcweirfi
300cdf0e10cSrcweir
301cdf0e10cSrcweir#run always
302cdf0e10cSrcweirfor theme in gnome hicolor locolor; do
303cdf0e10cSrcweir  if [ -e /usr/share/icons/$theme/icon-theme.cache ] ; then
304cdf0e10cSrcweir   # touch it, just in case we cannot find the binary...
305cdf0e10cSrcweir    touch /usr/share/icons/$theme
306cdf0e10cSrcweir    if [ -x /opt/gnome/bin/gtk-update-icon-cache ]; then
307cdf0e10cSrcweir      /opt/gnome/bin/gtk-update-icon-cache -q /usr/share/icons/$theme
308cdf0e10cSrcweir    elif (which gtk-update-icon-cache); then
309cdf0e10cSrcweir      gtk-update-icon-cache -q /usr/share/icons/$theme
310cdf0e10cSrcweir    fi
311cdf0e10cSrcweir    # ignore errors (e.g. when there is a cache, but no index.theme)
312cdf0e10cSrcweir    true
313cdf0e10cSrcweir  fi
314cdf0e10cSrcweirdone
315cdf0e10cSrcweir
316cdf0e10cSrcweir%files
317cdf0e10cSrcweir# specify stale symlinks verbatim, not as glob - a change in recent versions of
318cdf0e10cSrcweir# glibc breaks rpm unless rpm is build with internal glob-matching (issue 49374)
319cdf0e10cSrcweir# https://bugzilla.redhat.com/beta/show_bug.cgi?id=134362
320cdf0e10cSrcweir%defattr(-, root, root)
321cdf0e10cSrcweir%attr(0755, root, root) /usr/bin/*
322cdf0e10cSrcweir/usr/share/applications/%unixfilename-base.desktop
323cdf0e10cSrcweir/usr/share/applications/%unixfilename-calc.desktop
324cdf0e10cSrcweir/usr/share/applications/%unixfilename-draw.desktop
325cdf0e10cSrcweir/usr/share/applications/%unixfilename-impress.desktop
326cdf0e10cSrcweir/usr/share/applications/%unixfilename-math.desktop
327cdf0e10cSrcweir/usr/share/applications/%unixfilename-printeradmin.desktop
328cdf0e10cSrcweir/usr/share/applications/%unixfilename-writer.desktop
329cdf0e10cSrcweir/usr/share/applications/%unixfilename-startcenter.desktop
330cdf0e10cSrcweir/usr/share/applications/%unixfilename-javafilter.desktop
331cdf0e10cSrcweir/usr/share/icons/gnome/*/apps/*png
332cdf0e10cSrcweir/usr/share/icons/gnome/*/mimetypes/*png
333cdf0e10cSrcweir/usr/share/icons/hicolor/*/apps/*png
334cdf0e10cSrcweir/usr/share/icons/hicolor/*/mimetypes/*png
335cdf0e10cSrcweir/usr/share/icons/locolor/*/apps/*png
336cdf0e10cSrcweir/usr/share/icons/locolor/*/mimetypes/*png
337cdf0e10cSrcweir/usr/share/mime/packages/*
338